Cisco Nexus N3K-C3432D-S Switch
- Global Price List Information (GPL)
-
Model: N3K-C3432D-S
-
Description:
-
Price: USDLast Update:
- End-of-Sale and End-of-Life Information (EOL/EOS)
- Release Date:
- End-of-Sale Date:
- End-of-Support Date:
- Description
- Datasheet
- Documents
- Videos
- Training
- Softwares
- Accessories & Spare Parts
- Global Price List
- Reviews (0)
The Cisco Nexus 3400-S series represents a significant advancement in the Nexus 3000 portfolio, serving as the first 400G-capable switch designed specifically for modern data centers. By utilizing 50 Gbps PAM4 SerDes technology, these switches deliver industry-leading performance-per-watt and low-latency connectivity. This series is engineered to meet the growing demands of high-scale data centers, providing robust analytics and efficient power management to simplify network fabric operations.
At the heart of this platform is the Cisco NX-OS operating system, which is built for modularity, resiliency, and serviceability. This data center-class OS ensures continuous availability and operational flexibility, supporting both traditional command-line interfaces and modern programmable APIs. The combination of high-performance hardware and a feature-rich software stack makes the Nexus 3400-S an ideal solution for organizations looking to scale their infrastructure while maintaining simplified management and reduced operational costs.
Product overview
The primary model in this series is the Cisco Nexus 3432D-S, a high-density switch equipped with 32 fixed 400-Gigabit Ethernet QSFP-DD ports. These ports are highly versatile, offering backward compatibility with QSFP56, QSFP28, and QSFP+ transceivers, which allows for flexible migration and integration into existing network environments. The hardware is designed for reliability, featuring dual-redundant power supplies, a 5+1 redundant fan configuration, and support for both port-side intake and port-side exhaust airflow schemes to accommodate various data center cooling requirements.
Beyond its physical connectivity, the switch is built for massive scalability and high-performance computing. It features a 12.8-Tbps ASIC and a powerful four-core CPU with 16 GB of DRAM, enabling wire-rate Layer 2 and Layer 3 switching. The platform also supports advanced network monitoring and automation tools, such as deep packet forensics and queue monitoring, which provide administrators with granular visibility into traffic patterns and potential bottlenecks.
Features and benefits
- High-Density 400G Performance: Provides 32 ports of 400G connectivity, allowing for a simplified fabric design with fewer switches and reduced hop counts.
- Industry-Leading Efficiency: Delivers high power efficiency and low latency, optimizing operational costs in large-scale data center environments.
- Advanced Network Analytics: Includes per-flow monitoring, queue forensics, and drop-packet forensics to ensure proactive network health management.
- Flexible Breakout Options: Supports various breakout configurations (e.g., 2x200G, 4x100G, 8x50G), enabling up to 128 ports of 100G or 168 ports of 50G.
- Robust Programmability: Offers extensive support for automation through Cisco NX-API, Python scripting, Linux containers, and standard JSON/XML APIs.
- High Availability: Features Virtual Port Channel (vPC) for loop-free Layer 2 multipathing and 512-way Equal-Cost Multipath (ECMP) routing for resilient Layer 3 designs.
- Automated Provisioning: Utilizes Power-On Auto Provisioning (POAP) for touchless bootup and configuration, significantly reducing deployment time.
- Comprehensive Software Licensing: Offers tiered licensing options, ranging from a standard feature set to an Essential License that unlocks advanced Layer 3 routing (BGP, OSPF, IS-IS) and telemetry capabilities.
- Versatile Cabling: Compatible with a wide range of fiber and copper solutions, including Active Optical Cables (AOC) and Direct-Attached Cables (DAC).
Cisco Nexus 3400-S overview
The Cisco Nexus 3400-S is the first 400G capable switch in the Nexus 3000 portfolio with 50 Gbps PAM4 Serial-Deserializers (SerDes), designed for data centers with industry-leading performance-per-watt power efficiency at low latency, offering leading analytics.
Main benefits of the Cisco Nexus 3400-S switches:
● With the 12.8-Tbps ASIC, the Cisco Nexus 3432D-S provides 32 ports of 400G, allowing customers to grow at scale with fewer numbers of switches in their fabric, simplifying management and reducing cost and number of hops.
● At 400G, the Cisco Nexus 3400-S offers the lowest latency in the industry at high power efficiency.
● Cisco Nexus 3400-S switches enable deep network analytics, offering per-flow monitoring, queue forensics, and drop-packet forensics to help monitor customer networks.

Cisco Nexus 3432D-S switch
The Cisco Nexus 3432D-S (Figure 1) is a Quad Small Form-Factor Pluggable – Double Density (QSFP-DD) switch with 32 ports that are backward-compatible with QSFP+, QSFP28, and QSFP56.
The Cisco Nexus 3432D-S has the following hardware configuration:
● 32 fixed 400-Gigabit Ethernet QSFP-DD ports with backward compatibility for QSFP56, QSFP28, and QSFP+
● Beacon LED
● Status LED
● Dual-redundant power supplies
● Redundant (5+1) fans
● Two 100/1000-Mbps SFP ports (in front ports 33 and 34)
● One RS-232 console port
● One RJ45 and one SFP management port
● One USB port
The Cisco Nexus 3432D-S supports both forward and reverse (port-side intake and port-side exhaust) airflow schemes with AC power inputs. Colored handles on each fan or power supply clearly indicate the airflow direction, as seen in Figures 2 and 3.

Cisco Nexus 3432D-S with Blue Handles Indicating Port-Side Exhaust Airflow
Cisco NX-OS software overview
Cisco NX-OS is a data center-class operating system built with modularity, resiliency, and serviceability at its foundation. Cisco NX-OS helps ensure continuous availability and sets the standard for mission-critical data center environments. The self-healing and highly modular design of Cisco NX-OS makes zero-impact operations a reality and provides exceptional operational flexibility.
Focused on the requirements of the data center, Cisco NX-OS provides a robust and comprehensive feature set that meets the networking requirements of present and future data centers. With an XML interface and a Command-Line Interface (CLI) like that of Cisco IOS Software, Cisco NX-OS provides state-of-the-art implementations of relevant networking standards as well as a variety of true data-center-class Cisco innovations.
The Cisco Nexus 3400-S provides:
Wire-rate layer 2 and 3 switching on all ports, with up to 25.6 Terabits per second (Tbps) with 7.2 Bpps at ingress and 10 Bpps at egress[2].
Robust programmability, with support for Cisco NX-API, Linux containers, XML, and JavaScript Object Notation (JSON) APIs, Python.
High performance and scalability, with a four-core CPU, 16 GB of DRAM, and 70 MB of dynamic buffer allocation, making the switch excellent for massively scalable data centers and big data applications.
Flexibility
● The Cisco Nexus 3432D-S supports break out for 2x200/50G, 4x100/50G/25G, and 8x50G, supporting up to 128 ports of 100G or up to 168 ports of 50G.
● Both fiber and copper cabling solutions are available for 10-, 25-, 40-, 50-, 100-, and 400-Gbps connectivity, including an Active Optical Cable (AOC) and a Direct-Attached Cable (DAC).
High availability
● Virtual Port Channel (vPC) technology provides layer 2 multipath through the elimination of Spanning Tree Protocol (STP). It also enables fully-utilized bisectional bandwidth and simplified layer 2 logical topologies without the need to change the existing management and deployment models.
● The 512-way [1] Equal-Cost Multipath (ECMP) routing enables the use of layer 3 fat-tree designs. This feature allows organizations to prevent network bottlenecks, increase resiliency, and add capacity with little network disruption.
● Advanced reboot capabilities include hot and cold patching2.
● The switch uses hot-swappable Power-Supply Units (PSUs) and fans.
Purpose-built Cisco NX-OS operating system with comprehensive, proven innovations
● Power-On Auto Provisioning (POAP) enables touchless bootup and configuration of the switch, drastically reducing provisioning time.
● Cisco Embedded Event Manager (EEM) and Python scripting enable automation and remote operations in the data center.
● Advanced buffer monitoring reports real-time buffer utilization per port and per queue, which allows organizations to monitor traffic bursts and application traffic patterns.
● Ethanalyzer is a built-in packet analyzer for monitoring and troubleshooting control-plane traffic and is based on the popular Wireshark open-source network protocol analyzer.
● Complete layer 3 routing protocol suites are supported, including Border Gateway Protocol (BGP), Open Shortest Path First (OSPF), Enhanced Interior Gateway Routing Protocol (EIGRP), Routing Information Protocol Version 2 (RIPv2) and Intermediate System to Intermediate System (IS-IS).
Table 1. Software licensing for the Cisco Nexus 3432D-S switch
| Software package |
Features supported |
| System default (no license required) |
● Comprehensive layer 2 feature set: VLAN, IEEE 802.1Q trunking, Link Aggregation Control Protocol (LACP), Unidirectional Link Detection (UDLD; standard and aggressive), Multiple Spanning Tree Protocol (MSTP), Rapid Spanning Tree Protocol (RSTP), and Spanning Tree Protocol guard
● Security: Authentication, Authorization, and Accounting (AAA), Access Control Lists (ACLs), storm control, and configurable Control-Plane Policing (CoPP)
● Management features: Cisco Data Center Network Manager (DCNM) support, Secure Shell Version 2 (SSHv2) access, Cisco Discovery Protocol, Simple Network Management Protocol (SNMP), syslog
● Monitoring features: Advanced buffer monitoring, Switched Port Analyzer (SPAN) and Encapsulated RSPAN (ERSPAN)
|
| Base license |
● Layer 3 IP routing: Inter-VLAN Routing (IVR), static routes, Routing Information Protocol Version 2 (RIPv2), ACLs, Open Shortest Path First Version 2 (OSPFv2; limited to 256 routes), Enhanced Interior Gateway Routing Protocol (EIGRP) stub, Hot Standby Router Protocol (HSRP), and Virtual Router Redundancy Protocol (VRRP)
|
| Essential License |
● Advanced layer 3 IP routing: OSPFv2, EIGRP, Border Gateway Protocol (BGP), and Intermediate System to Intermediate System (IS-IS), and Virtual Routing and Forwarding Lite (VRF-Lite) and Telemetry Features: Buffer Drop Capture (BDC), High Delay Capture (HDC) and INT
|
| Cisco Nexus Data Broker license (NDB-FX-SWT-K9) |
● License for using the tap and SPAN aggregation functions with Cisco Nexus Data Broker; supported on Essential License
|
Product specifications
The following tables list the product specifications, software features, and management and standards support for the Cisco Nexus 3400-S platforms.
Table 2. Product specifications
| Specification |
Cisco Nexus 3432D-S |
| Physical |
● 32 fixed 400-Gigabit-Ethernet QSFP-DD ports
● Beacon LED
● Status LED
● Dual-redundant power supplies
● Redundant (5+1) fans
● Two 100/1000Mbps SFP ports in front (ports 33 and 34)
● One RS-232 serial console port
● One RJ45 and one SFP management port
● One USB port
|
| Performance |
25.6 Tbps switching capacity |
| Typical operating power |
626W |
| Maximum power |
1240W |
| Typical heat dissipation |
2136 BTU/hr |
| Maximum heat dissipation |
4231 BTU/hr |
Table 3. Hardware specifications for Nexus 3400-S platforms
| Mode |
Normal mode |
|
| Hardware tables and scalability |
Number of MAC addresses |
120K |
| Number of IPv4/IPv6 unicast routes |
440K / 360K |
|
| Number of IPv4/IPv6 hosts |
192K / 96K |
|
| Number of IPv4 multicast routes |
Up to 96K with 8K groups |
|
| Number of VLANS |
4K |
|
| Number of ACL entries |
3.5K ingress and 1.5K egress |
|
| Number of spanning-tree instances |
Rapid Spanning Tree Protocol (RSTP): 123 Multiple Spanning Tree (MST) Protocol: 64 |
|
| Number of EtherChannels |
24 |
|
| Number of ports per EtherChannel |
24 |
|
| Buffer size |
70 MB |
|
| Boot flash memory |
128 GB |
|
| Number of power supplies |
2 (redundant) |
|
| Power supply types |
AC (forward and reversed airflow) |
|
| Input voltage |
100 to 240 VAC |
|
| Frequency |
50 to 60 Hz |
|
| Power supply efficiency |
89 to 91% at 220V |
|
| Cooling |
Forward and reversed airflow schemes
● Forward airflow: Port-side intake (air enters through ports and exits through fan tray and power supplies)
● Reversed airflow: Port-side exhaust (air enters through fan tray and power supplies and exits through ports)
Six individual, hot-swappable fans (5+1 redundant) |
|
| Environment |
Dimensions (height x width x depth) |
1.75 x 17.29 x 25.4 in. (4.44 x 43.91 x 64.51cm) |
| Weight |
30 pounds or 13.6 Kg |
|
| Operating temperature |
32 to 104° F (0 to 40°C) |
|
| Storage temperature |
-40 to 158° F (-40 to 70°C) |
|
| Relative humidity |
5 to 95% non-condensing |
|
| Altitude (Operating) |
Up to 13,123 ft. |
|
| Altitude (Non-Operating) |
Up to 16,000 ft. |
|
Transceiver and cabling options
The Cisco Nexus 3400-S are Quad Small Form factor pluggable – Double Density (QSFP-DD) platforms that support the full range of optical transceivers, starting from Active Optical Cables (AOC), Direct Attach Cables (DAC).
For details about the optical modules available and the minimum software release required for each supported optical module, visit here.
Table 4. Software features common to Nexus 3000 series switches
| Description |
Specifications |
| Layer 2 |
● Layer 2 switch ports and VLAN trunks
● IEEE 802.1Q VLAN encapsulation
● Support for up to 4096 VLANs
● Rapid Per-VLAN Spanning Tree Plus (PVRST+) (IEEE 802.1w compatible)
● MSTP (IEEE 802.1s): 64 instances
● Spanning Tree PortFast
● Spanning Tree Root Guard
● Spanning Tree Bridge Assurance
● Cisco EtherChannel technology (up to 24 ports per EtherChannel)
● LACP: IEEE 802.3ad, IEEE 802.1ax
● Advanced PortChannel hashing based on layer 2, 3, and 4 information
● Jumbo frames on all ports (up to 9216 bytes)
● Link-level flow control (IEEE 802.3x)
● vPC
|
| Layer 3 |
● Layer 3 interfaces: Routed ports on interfaces, Switch Virtual Interfaces (SVIs), PortChannels, and subinterfaces (total: 1024)
● 64-way Equal-Cost Multipath (ECMP)
● 4096 ACL entries
● Routing protocols: Static, RIPv2, EIGRP, OSPF, IS-IS, and BGP
● HSRP and VRRP
● ACL: Routed ACL with layer 3 and 4 options to match ingress and egress ACLs
● VRF: VRF-Lite (IP VPN), VRF-aware unicast (BGP, OSPF, and RIP), and VRF‑aware multicast
● VRF route leaking
● Jumbo frame support (up to 9216 bytes)
|
| Security |
● Ingress ACLs (standard and extended) on Ethernet
● Standard and extended layer 3 to 4 ACLs include IPv4, Internet Control Message Protocol (ICMP), Transmission Control Protocol (TCP), and User Datagram Protocol (UDP)
● VLAN-based ACLs (VACLs)
● Port-based ACLs (PACLs)
● ACLs on virtual terminals (VTYs)
● Dynamic Host Configuration Protocol (DHCP) relay
● Control Plane Policing (CoPP)
|
| Cisco Nexus Data Broker |
● Topology support for tap and SPAN aggregation
● Traffic load balancing to multiple monitoring tools
● Packet truncation
● Traffic filtering based on layer 1 through layer 4 header information
● Traffic replication and forwarding to multiple monitoring tools
● Robust Role-Based Access Control (RBAC)
● Northbound Representational State Transfer (REST) API for all programmability support
|
| Management |
● Power On Auto Provisioning (POAP)
● Python scripting
● Switch management using 10/100/1000-Mbps management or console ports
● CLI-based console to provide detailed out-of-band management
● In-band switch management
● Locator and beacon LEDs
● Configuration rollback
● SSHv2
● Telnet
● AAA
● AAA with RBAC
● RADIUS
● TACACS+
● Syslog
● Embedded packet analyzer
● SNMP v1, v2, and v3
● Enhanced SNMP MIB support
● XML (NETCONF) support
● Remote monitoring (RMON)
● Advanced Encryption Standard (AES) for management traffic
● Unified username and passwords across CLI and SNMP
● Microsoft Challenge Handshake Authentication Protocol (MS-CHAP)
● Digital certificates for management between switch and RADIUS server
● Cisco Discovery Protocol (CDP) Versions 1 and 2
● RBAC
● SPAN on physical, PortChannel, and VLAN
● ERSPAN Versions 2 and 3
● Ingress and egress packet counters per interface
● Network Time Protocol (NTP)
● Cisco Online Health Management System (OHMS)
● Comprehensive bootup diagnostic tests
● Cisco Data Center Network Manager (DCNM)
● Active buffer monitoring
|
Table 5. Management and standards support
| Description |
Specification |
|
| MIB support |
Generic MIBs
● SNMPv2-SMI
● CISCO-SMI
● SNMPv2-TM
● SNMPv2-TC
● IANA-ADDRESS-FAMILY-NUMBERS-MIB
● IANAifType-MIB
● IANAiprouteprotocol-MIB
● HCNUM-TC
● CISCO-TC
● SNMPv2-MIB
● SNMP-COMMUNITY-MIB
● SNMP-FRAMEWORK-MIB
● SNMP-NOTIFICATION-MIB
● SNMP-TARGET-MIB
● SNMP-USER-BASED-SM-MIB
● SNMP-VIEW-BASED-ACM-MIB
● CISCO-SNMP-VACM-EXT-MIB
Ethernet MIBs
● CISCO-VLAN-MEMBERSHIP-MIB
Configuration MIBs
● ENTITY-MIB
● IF-MIB
● CISCO-ENTITY-EXT-MIB
● CISCO-ENTITY-FRU-CONTROL-MIB
● CISCO-ENTITY-SENSOR-MIB
● CISCO-SYSTEM-MIB
● CISCO-SYSTEM-EXT-MIB
● CISCO-IP-IF-MIB
● CISCO-IF-EXTENSION-MIB
● CISCO-NTP-MIB
● CISCO-IMAGE-MIB
● CISCO-IMAGE-UPGRADE-MIB
|
Monitoring MIBs
● NOTIFICATION-LOG-MIB
● CISCO-SYSLOG-EXT-MIB
● CISCO-PROCESS-MIB
● RMON-MIB
● CISCO-RMON-CONFIG-MIB
● CISCO-HC-ALARM-MIB
Security MIBs
● CISCO-AAA-SERVER-MIB
● CISCO-AAA-SERVER-EXT-MIB
● CISCO-COMMON-ROLES-MIB
● CISCO-COMMON-MGMT-MIB
● CISCO-SECURE-SHELL-MIB
Miscellaneous MIBs
● CISCO-LICENSE-MGR-MIB
● CISCO-FEATURE-CONTROL-MIB
● CISCO-CDP-MIB
● CISCO-RF-MIB
Layer 3 and Routing MIBs
● UDP-MIB
● TCP-MIB
● OSPF-MIB
● OSPF-TRAP-MIB
● BGP4-MIB
● CISCO-HSRP-MIB
|
| Standards |
● IEEE 802.1D: Spanning Tree Protocol
● IEEE 802.1p: CoS Prioritization
● IEEE 802.1Q: VLAN Tagging
● IEEE 802.1s: Multiple VLAN Instances of Spanning Tree Protocol
● IEEE 802.1w: Rapid Reconfiguration of Spanning Tree Protocol
● IEEE 802.3z: Gigabit Ethernet
● IEEE 802.3ad: Link Aggregation Control Protocol (LACP)
● IEEE 802.1ax: Link Aggregation Control Protocol (LACP)
● IEEE 802.3ae: 10 Gigabit Ethernet
● IEEE 802.3ba: 40 Gigabit Ethernet
● IEEE 802.1ab: Link Layer Discovery Protocol (LLDP)
|
|
| RFC |
BGP
● RFC 1997: BGP Communities Attribute
● RFC 2385: Protection of BGP Sessions with the TCP MD5 Signature Option
● RFC 2439: BGP Route Flap Damping
● RFC 2519: A Framework for Inter-Domain Route Aggregation
● RFC 2545: Use of BGPv4 Multiprotocol Extensions
● RFC 2858: Multiprotocol Extensions for BGPv4
● RFC 3065: Autonomous System Confederations for BGP
● RFC 3392: Capabilities Advertisement with BGPv4
● RFC 4271: BGPv4
● RFC 4273: BGPv4 MIB: Definitions of Managed Objects for BGPv4
● RFC 4456: BGP Route Reflection
● RFC 4486: Subcodes for BGP Cease Notification Message
● RFC 4724: Graceful Restart Mechanism for BGP
● RFC 4893: BGP Support for Four-Octet AS Number Space
OSPF
● RFC 2328: OSPF Version 2
● 8431RFC 3101: OSPF Not-So-Stubby-Area (NSSA) Option
● RFC 3137: OSPF Stub Router Advertisement
● RFC 3509: Alternative Implementations of OSPF Area Border Routers
● RFC 3623: Graceful OSPF Restart
● RFC 4750: OSPF Version 2 MIB
RIP
● RFC 1724: RIPv2 MIB Extension
● RFC 2082: RIPv2 MD5 Authentication
● RFC 2453: RIP Version 2
● IP Services
● RFC 768: User Datagram Protocol (UDP)
● RFC 783: Trivial File Transfer Protocol (TFTP)
● RFC 791: IP
● RFC 792: Internet Control Message Protocol (ICMP)
● RFC 793: TCP
● RFC 826: Address Resolution Protocol (ARP)
● RFC 854: Telnet
● RFC 959: FTP
● RFC 1027: Proxy ARP
● RFC 1305: Network Time Protocol (NTP) Version 3
● RFC 1519: Classless Interdomain Routing (CIDR)
● RFC 1542: BootP Relay
● RFC 1591: Domain Name System (DNS) Client
● RFC 1812: IPv4 Routers
● RFC 2131: DHCP Helper
● RFC 2338: VRRP
|
|
Regulatory standards compliance
The following table summarizes regulatory standards compliance for the Cisco Nexus 3000 Series.
Table 6. Regulatory standards compliance: Safety and EMC
| Specification |
Description |
| Regulatory compliance |
● Products should comply with CE Markings per directives 2004/108/EC and 2006/95/EC
|
| Safety |
● UL 60950-1 Second Edition
● CAN/CSA-C22.2 No. 60950-1 Second Edition
● EN 60950-1 Second Edition
● IEC 60950-1 Second Edition
● AS/NZS 60950-1
● GB4943
|
| EMC: Emissions |
● 47CFR Part 15 (CFR 47) Class A
● AS/NZS CISPR22 Class A
● CISPR22 Class A
● EN55022 Class A
● ICES003 Class A
● VCCI Class A
● EN61000-3-2
● EN61000-3-3
● KN22 Class A
● CNS13438 Class A
|
| EMC: Immunity |
● EN55024
● CISPR24
● EN300386
● KN24
|
| RoHS |
RoHS 5 compliant except for lead press-fit connectors |
Ordering information
The following table provides ordering information for Cisco Nexus 3432D-S Switch.
Table 7. Ordering information
| Part number |
Description |
| Chassis |
|
| N3K-C3432D-S |
Nexus 3432D-S switch with 32ports of QSFP-DD |
| NXA-FAN-35CFM-PE |
Nexus Fan, Reverse airflow (port side exhaust) |
| NXA-FAN-35CFM-PI |
Nexus Fan, Forward airflow (port side intake) |
| NXA-PAC-1500W-PE |
Nexus 1500W AC Power Supply, Reverse airflow (port side exhaust) |
| NXA-PAC-1500W-PI |
Nexus 1500W AC Power Supply, Forward airflow (port side intake) |
| Software Licenses |
|
| N3K-ES-XF2 |
Nexus 3432D-S Essential License including Layer-3 LAN Enterprise and Telemetry features |
| Spares |
|
| NXA-FAN-35CFM-PE= |
Nexus Fan, Reverse airflow (port side exhaust) spare |
| NXA-FAN-35CFM-PI= |
Nexus Fan, Forward airflow (port side intake) spare |
| NXA-PAC-1500W-PE= |
Nexus 1500W AC Power Supply, Reverse airflow (port side exhaust) spare |
| NXA-PAC-1500W-PI= |
Nexus 1500W AC Power Supply, Forward airflow (port side intake) spare |
For more information
For more information, visit https://www.cisco.com/go/nexus3000. For information about Cisco Nexus Data Broker, visit https://www.cisco.com/go/nexusdatabroker.
| Model | N3K-C3432D-S |
